学科:IOS/KB/调试不能

来自维基学院
跳到导航 跳到搜索

不能在老旧的设备上运行[编辑 | 编辑源代码]

对于armv6的设备:

  • 移除 info.plist 里的 Required device capabilities 这项
  • 编译选项中的 Architectures 若没有armv6 这项,需要加上
  • 如果应用图标出现在设备上了,但应用还是跑不起来,Xcode无任何提示,需要检查设备日志

Error launching remote program: failed to get the task for process[编辑 | 编辑源代码]

要点:

  • 以发布模式(如AdHoc)编译出的应用不能被调试
  • 尝试重启Xcode或Mac

参考:http://stackoverflow.com/q/2182249/945906

Could not change executable permissions on the application[编辑 | 编辑源代码]

把设备或模拟器上的应用删除后再试。